vMX
Highlighted
vMX

vMX in a clustered VMware Environment

‎12-23-2019 03:21 PM

Hello everyone,

 

I am wondering if there is a fix to this issue I am having and pretty surprised I could not find a topic on it already. I have the latest release of vMX (19.3). My router works just fine if both VMs reside on the same host but we have 3 hosts running HA.

 

I deployed the VMs to the cluster rather than a specific host and put the VMs into a distributed port group. If both the VCP and the VFP are on the same host, everything is great. If they are on different hosts, I cannot ping between them on the __juniper_private1__ VRF nor can the VCP see any FPCs at all (they all say empty).

 

Logically, to my tiny little brain, it shouldn't matter if they are on different hosts if using a distributed port group. Is there something that maybe I have to configure on my physical switch to get it to function? I would like HA to kick in if neccessary and am worried it will send the VMs to different hosts.

 

Thanks for any help and I am sorry if this has been posted before, I could not find it.

1 REPLY 1
vMX

Re: vMX in a clustered VMware Environment

‎12-24-2019 08:05 AM

Just a quick update. My routers were moving around when rebooted because I forgot that I turned DRS on as well. Easy fix there but still pretty concerned about HA moving the VMs to different hosts.

 

Has no one ran vMX routers on a HA environment? The only solution I can come up with at the moment is to remove a host so there are only two so if one fails, they have to move to the same host.