vMX
Highlighted
vMX

vMX in vLabs and VLANs

2 weeks ago

Hi,

 

I've been playing with the vMX in vLabs, just trying to get some subinterfaces working (I'm more familiar with the EX series).

However, I can't create any VLANs. Is this normal for MX/vMX, or is it a limitation with vLabs?

 

Just trying to work out if I'm doing something wrong here.

 

Thanks

5 REPLIES 5
Highlighted
vMX

Re: vMX in vLabs and VLANs

[ Edited ]
2 weeks ago

FYI, I've now also tried this with vSRX.

I have two vSRX connected directly together on ge-0/0/1.

I've then added this config to make two subinterfaces:

 

jcluser@vSRX1# show interfaces ge-0/0/1    
vlan-tagging;
unit 100 {
    vlan-id 100;
    family inet {
        address 192.168.100.1/24;
    }
}
unit 200 {
    vlan-id 200;
    family inet {
        address 192.168.200.1/24;
    }
}

 

Each srx can ping their own IP's, but not the neighbour IP's.

Any ideas where I'm going wrong?

 

 

 

Highlighted
vMX

Re: vMX in vLabs and VLANs

Wednesday

Hi,

 

Same configuration as configured on SRX should work on vMX.

 

Can you share the vMX interface config.

 

Also share output of "show chassis hardware"

-
VR
# Please mark my solution as accepted if it helped, Kudos are appreciated as well.
Highlighted
vMX
Solution
Accepted by topic author Luke Robertson
Sunday

Re: vMX in vLabs and VLANs

[ Edited ]
Wednesday

Hi Luke Robertson, 

 

In my knowledge, on the MX/vMX devices we have bridge domains instead of vlan. The below configuration might help you in understanding the steps to establish reachability between different VLANs (bridge domain) :

set interfaces ge-0/0/0 unit 0 family bridge interface-mode access
set interfaces ge-0/0/0 unit 0 family bridge vlan-id 10
set interfaces ge-0/0/1 unit 0 family bridge interface-mode access

set interfaces ge-0/0/1 unit 0 family bridge vlan-id 20
set bridge-domains vlan-a vlan-id 10
set bridge-domains vlan-b vlan-id 20

set interfaces irb unit 10 family inet address 10.10.10.1/24
set interfaces irb unit 20 family inet address 20.20.20.1/24
set bridge-domains vlan-a routing-interface irb.10
set bridge-domains vlan-b routing-interface irb.20

 

Please mark "accept as solution" if this answers your query. Kudos are appreciated too ! 

 

Regards,
Sharat

Highlighted
vMX

Re: vMX in vLabs and VLANs

Sunday

Thanks. I have found that the vMX (vlabs or otherwise) do not support VLANs in the way I'm attempting.

 

I will have a look at bridge domains instead. Thanks.

 

 

Highlighted
vMX

Re: vMX in vLabs and VLANs

yesterday

Hi Luke, 

 

Please explore and do let me know if you have any further queries on this. 


Regards,
Sharat