vMX
vMX

vMX installation issue on CentOS

a week ago

Anyone can please hint what is the issue here? before this I was not able install kmod-ixgbe. Could that be the issue? Full log attached.

 

[root@arifr-baremetal01 vmx]# lsb_release -a
LSB Version: :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarchSmiley Tonguerinting-4.1-amd64Smiley Tonguerinting-4.1-noarch
Distributor ID: CentOS
Description: CentOS Linux release 7.7.1908 (Core)
Release: 7.7.1908
Codename: Core
[root@arifr-baremetal01 vmx]# yum install kmod-ixgbe
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* centos-sclo-rh: centos.sonn.com
* centos-sclo-sclo: mirrors.xmission.com
No package kmod-ixgbe available.
Error: Nothing to do
[root@arifr-baremetal01 vmx]#

 

==================================================
    System Setup Completed
==================================================
 
[Command] brctl show br-ext | grep bond0
can't get info No such device
Get Management Address of bond0...................
[Command] expr "10.122.172.238" != ""
1
[OK]
Generate libvirt files............................
[Command] python /root/vmx/vmx/scripts/common/vmx_configure.py /root/vmx/vmx/config/vmx.conf
[Failed]
Traceback (most recent call last):
  File "/root/vmx/vmx/scripts/common/vmx_configure.py", line 3, in <module>
    import yaml
  File "/opt/rh/python27/root/usr/lib64/python2.7/site-packages/yaml/__init__.py", line 8, in <module>
    from loader import *
  File "/opt/rh/python27/root/usr/lib64/python2.7/site-packages/yaml/loader.py", line 4, in <module>
    from reader import *
  File "/opt/rh/python27/root/usr/lib64/python2.7/site-packages/yaml/reader.py", line 47, in <module>
    class Reader(object):
  File "/opt/rh/python27/root/usr/lib64/python2.7/site-packages/yaml/reader.py", line 140, in Reader
    NON_PRINTABLE = re.compile(u'[^
 -~
𐀀-􏿿]')
  File "/opt/rh/python27/root/usr/lib64/python2.7/re.py", line 194, in compile
    return _compile(pattern, flags)
  File "/opt/rh/python27/root/usr/lib64/python2.7/re.py", line 249, in _compile
    p = sre_compile.compile(pattern, flags)
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 576, in compile
    code = _code(p, flags)
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 558, in _code
    _compile_info(code, p, flags)
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 536, in _compile_info
    _compile_charset(charset, flags, code)
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 232, in _compile_charset
    flags & SRE_FLAG_UNICODE):
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 386, in _optimize_charset
    data[0:0] = [block] + _bytes_to_codes(mapping)
  File "/opt/rh/python27/root/usr/lib64/python2.7/sre_compile.py", line 418, in _bytes_to_codes
    import array
ImportError: /opt/rh/python27/root/usr/lib64/python2.7/lib-dynload/arraymodule.so: undefined symbol: _PySlice_Unpack
Log file........................................../root/vmx/vmx/build/vmx1/logs/vmx_1573235865.log
==================================================
 Aborted!. 1 error(s) and 0 warning(s)
================================================== 

Attachments

1 REPLY 1
vMX

Re: vMX installation issue on CentOS

a week ago

Hi,

 

Any changes done with repositry mirror links?

 

Also 7.7 is not recommened CentOS version for vMX. Can you try with 7.2 or 7.5 ?

 

https://www.juniper.net/documentation/en_US/vmx/topics/reference/general/vmx-hw-sw-minimums.html

-
VR
# Please mark my solution as accepted if it helped, Kudos are appreciated as well.