vSRX
vSRX

How to install DHCP for VLAN in SRX300

[ Edited ]
‎08-15-2019 06:23 PM

I have a diagram as same as bellow:

srx1.PNG

I want to configure DHCP for VLAN10 to clients can get ip information dynamically from the Router (my dhcp configured here).

here is configuration Juniper recommend:

////

set system services ssh
set security policies from-zone Trust to-zone Untrust policy trust-untrust match source-address any
set security policies from-zone Trust to-zone Untrust policy trust-untrust match destination-address any
set security policies from-zone Trust to-zone Untrust policy trust-untrust match application any
set security policies from-zone Trust to-zone Untrust policy trust-untrust then permit

set security policies from-zone Untrust to-zone DMZ policy trust-untrust match source-address any
set security policies from-zone Untrust to-zone DMZ policy trust-untrust match destination-address any
set security policies from-zone Untrust to-zone DMZ policy trust-untrust match application junos-http
set security policies from-zone Untrust to-zone DMZ policy trust-untrust match application junos-https
set security policies from-zone Untrust to-zone DMZ policy trust-untrust then permit

set security policies from-zone Trust to-zone DMZ policy trust-untrust match source-address any
set security policies from-zone Trust to-zone DMZ policy trust-untrust match destination-address any
set security policies from-zone Trust to-zone DMZ policy trust-untrust match application any
set security policies from-zone Trust to-zone DMZ policy trust-untrust then permit

set security zones security-zone MGMT host-inbound-traffic system-services all
set security zones security zone MGMT interface ge-0/0/0.0
set security zones security-zone Untrust interfaces ge-0/0/1.0
set security zones security-zone DMZ interfaces ge-0/0/2.0
set security zones security-zone Trust interfaces ge-0/0/3.0

set interfaces ge-0/0/0 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members vlan-20
set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members vlan-10
set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members vlan-10
set interfaces ge-0/0/3 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/3 unit 0 family ethernet-switching vlan members vlan-10
set interfaces irb unit 20 family inet address 10.0.0.254/24

set protocols l2-learning global-mode transparent-bridge
set vlans vlan-10 vlan-id 10
set vlans vlan-20 vlan-id 20
set vlans vlan-20 l3-interface irb.20

////

What I need change? thank you so much!

5 REPLIES 5
vSRX

Re: How to install DHCP for VLAN in SRX300

‎08-15-2019 11:52 PM

Can you pl paste your complete configuration?

 

Also show the how the 192.168.0.0/24 is associated to SRX ?? Does it have gateway on SRX or on some L3 switch?


*************************************
HTH.
Accept this as solution if it resolved your issue.
Kudos would be appreciated too.
vSRX

Re: How to install DHCP for VLAN in SRX300

‎08-16-2019 12:56 AM

@milindmistry

this is an example of juniper about transparent mode on srx device. Its also model i need. but i want clients (in VLAN10) to get ip dynamically instead of setting static ip for them.

vSRX

Re: How to install DHCP for VLAN in SRX300

a month ago
 

*************************************
HTH.
Accept this as solution if it resolved your issue.
Kudos would be appreciated too.
vSRX

Re: How to install DHCP for VLAN in SRX300

a month ago
vSRX

Re: How to install DHCP for VLAN in SRX300

4 weeks ago
You can attach an IP address to the irb where you need a DHCP server. For the same vlan, gateway can be on another switches as well.

*************************************
HTH.
Accept this as solution if it resolved your issue.
Kudos would be appreciated too.