vSRX
vSRX

J-Web Access not working

‎12-27-2018 03:51 AM

Hi

 

Below is the configuration on vSRX and it doesn`t seem to be working as on accessing through Web ( http/https) it  gives

 

"The page isn’t redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies. "

 

set system services ssh root-login allow
set system services web-management management-url https://192.168.104.225/root
set system services web-management http interface fxp0.0
set system services web-management https port 443
set system services web-management https system-generated-certificate
set system services web-management https interface fxp0.0

 

I have tried multiple browsers its the same, have tried restarting the Web-managment.

SSH works fine. 

 

Kindly advise.

 

Thanks

10 REPLIES 10
vSRX

Re: J-Web Access not working

‎12-27-2018 04:03 AM

you shall only include the part after the IP address in the management-url configuration. In this example "management-url root".


--
Best regards,

Jonas Hauge Klingenberg
Systems Engineer, SEC DATACOM A/S (Denmark)
vSRX

Re: J-Web Access not working

‎12-27-2018 04:08 AM

Please refer this KB for more details : https://kb.juniper.net/InfoCenter/index?page=content&id=KB19411&smlogin=true&actp=search

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
vSRX

Re: J-Web Access not working

‎12-27-2018 03:54 PM

Thank you for the response.

 

Made correction but its still the same.

 

Thanks

vSRX

Re: J-Web Access not working

‎12-27-2018 10:32 PM

What is the software version of vSRX?

 

Could you try this:

Use the following operational command to delete the automatically generated self-signed certificate:

 clear security pki local-certificate system-generated

 

After you delete the system-generated self-signed certificate, the device automatically generates a new one and saves it in the file system.

If this also does not help get web access, please provide the complete config along with show log messages.

 

Thanks,

Pranita

vSRX

Re: J-Web Access not working

[ Edited ]
‎12-28-2018 01:53 PM

Hi Pranita

 

Thank you !

 

 On clearing the certificate it gave the security prompt for certificate (Snapshot attached) but ultimately its still the same.

output of "show configuration" and "show log" is also attached.

 

Kindly advise.

 

Warm regards

Jenander Sishodia

Attachments

vSRX

Re: J-Web Access not working

‎12-28-2018 01:57 PM

hi Nellikka

 

It didnt`t work.

 

Thank you

vSRX

Re: J-Web Access not working

‎12-30-2018 04:05 AM

Hi Jenander,

 

Thank you for attaching the files. Unfortunately, the log file only contains the log files list. Could you capture the output for messages file from it? The command is show log messages.

Are you saying that the jweb access fails even after adding the security exception for vSRX ip on the browser? Can you share screenshot of the error message seen after the exception is added?

 

Thanks,
Pranita

vSRX

Re: J-Web Access not working

‎12-30-2018 03:53 PM

Hi Pranita

 

Yes, that is correct. It doesn`t open GUI even after adding security exception and under trusted site. 

Error snapshot and out of Show log messages is attached.

 

Just for FYI, this is my 1st encounter with Juniper as am from CISCO background.

 

Thanks

Attachments

vSRX
Solution
Accepted by topic author jsishodia
‎12-31-2018 03:47 AM

Re: J-Web Access not working

‎12-31-2018 02:03 AM

Hello Jenander,

 

Thank you for the logs! The phone home feature is enabled and is causing the redirect to fail.

 

Please try Jweb access after the following change:

 

delete system phone-home

 

Apparently the phone-home “feature” is somehow commandeering all web services, and will break JWEB.

 

Hopefully this helps.

 

Thanks,

Pranita

vSRX

Re: J-Web Access not working

‎12-31-2018 03:48 AM

Hi Pranita

 

Thanks a ton.

It is working fine now.

 

Wish you a Happy New Year ahead.

 

Warm regards

Jenander Sishodia