vSRX
Highlighted
vSRX

Newbie VSRX

‎04-09-2019 03:15 AM

Hello Everyone,

 

                 Please bare with me as I am new to juniper and still in learning mode. I have downloaded the VSRX vmdisk-15.1X49-D170.4.hyperv and successfully started in Hyperv windows server 2012. I have physically 2 Ethernets on the server out of which 1 is used as fxp0 for management and another is ge-0/0/0.

 

when I type the command

sh interfaces terse I dont see ge-0/0/0 but on another hand I can see the interface (ge-0/0/0) in the GUI.

 

Please help me to get rid from this consfusion. Please check the attached pictures as well

13 REPLIES 13
Highlighted
vSRX

Re: Newbie VSRX

‎04-09-2019 03:18 AM

Hi,

 

Welcome to the Community!!!

Can you try configuring ge-0/0/0 first and then check from CLI? Something like -> 'set interfaces ge-0/0/0 unit 0 family inet' should do the trick.

Regards,
Gokul
Highlighted
vSRX

Re: Newbie VSRX

‎04-09-2019 03:43 AM

Yes I did but nothing is shown, please check the below

 

root@# set interfaces ge-0/0/0 unit 0 family inet dhcp-client

Highlighted
vSRX

Re: Newbie VSRX

‎04-09-2019 10:59 PM

updates on this issue ?

Highlighted
vSRX

Re: Newbie VSRX

‎04-15-2019 03:51 AM

No Updates ??

Highlighted
vSRX

Re: Newbie VSRX

‎04-15-2019 08:46 AM

Hi,

Can you share with me the steps done to deploy the vsrx ? also the allocated resources for the vm ?
also a quick question, did you created Hyper-v virtual switch as it is necessary to support the fpx0 and traffic interfaces on vSRX VM ?

 

Thanks,

Amr 

 

Regards,
A.A.
Highlighted
vSRX

Re: Newbie VSRX

‎04-15-2019 11:18 PM

Hi there,

 

Are you trying to deploy VSRX on Azure cloud?

What type of VSRX flavour are you trying to accomplish? Multicore or SingleCore?

 

I will be waiting for your response,

 

Best Regards,

Allan Quiros

 

 

Highlighted
vSRX

Re: Newbie VSRX

‎04-17-2019 12:16 AM

I have Hyper v on server 2012 on which I have deployed 15.1X49-D80 and Junos OS Release 17.3R1.

I have physical 3 network card.

 

created a Hyperv Switch all external with the names Ge/0/0/0,Ge/0/0/1,Ge/0/0/2

 

fxp0 is shown and pinging very well with host and on top of that I am also using the jweb from the the hyperv host.

The only thing Which I am facing is cannot be able to see the other 2 interfaces in the cli.

 

Hope you understand and If you need more help please do let me know.

Highlighted
vSRX

Re: Newbie VSRX

‎04-17-2019 12:20 AM

No I am trying it on local lab @ my company.

15.1X49-D80 and Junos OS Release 17.3R1

Multicore

we have srx 240 and would test  and migrate on vsrx

 

 

Highlighted
vSRX

Re: Newbie VSRX

‎04-18-2019 04:06 AM

Hi,

 

Then after creating the virtual switches you should do the following:

1 - right click vSRX VM and select settings from context menu. from the settings dialog box, under hardware section click Network Adaptor

2 - from Virtual switch drop down menu choose the desired Virtual switch.

3 - click apply and OK to save the configurations 

 

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."

 

 

Regards,
A.A.
Highlighted
vSRX

Re: Newbie VSRX

‎04-18-2019 05:43 AM

Done. Nothing had happened. I have followed this article as well 

 

https://www.juniper.net/documentation/en_US/vsrx/topics/task/multi-task/security-vsrx-hyper-v-manage...

Highlighted
vSRX

Re: Newbie VSRX

‎04-18-2019 06:32 AM

Could you check the memory allocated to VM as it may be not sufficient , try to increase the allocated memory and reboot the VM and check if interfaces appear.

 

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."

 

 

Regards,
A.A.
Highlighted
vSRX

Re: Newbie VSRX

‎04-18-2019 10:59 PM

1: Is your PFE coming up ?

 

show chassis fpc pic-status

 

2: Do you see any anomaly in the "show system boot-messages" ?

 

3: Do you see any error in the console ? not ssh etc

 

Thanks,

Vikas

 

 

 

Highlighted
vSRX

Re: Newbie VSRX

‎06-24-2019 04:59 PM

Hi Cigalah,

 

Unsure what your status is on this, but here is a deployment guide for Hyper-V that should help you.

 

https://www.juniper.net/documentation/en_US/vsrx/information-products/pathway-pages/security-vsrx-hy...

 

Do let us know if this issue needs any further assistance.

Cheers

Pooja 

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!