vSRX
Highlighted
vSRX

eve-ng vSRX Constantly power cycling

‎12-27-2019 02:40 AM

Hi,

 

I have eve-ng running fine with 2 x vMX currently (CP and FP) and have installed a vSRX (as I need to test some VPN/NAT configurations).

 

When I power on the vSRX I get to the following point:

JUNOS procfs is initialized.
Timecounters tick every 1.000 msec
can't re-use a leaf (pvidb_rootnode)!
Registering tcp_platform_dependent = tcp_handle_special_ports
md0: Preloaded image </packages/sets/active/boot/os-kernel/contents.izo> 8897024 bytes at 0xffffffff824e41c0
SMP: AP CPU #1 Launched!
Kernel thread "wkupdaemon" (pid 43) exited prematurely.
Trying to mount root from cd9660:/dev/md0.uzip []...
mode = 0100644, inum = 6910, fs = /.mount
panic: ffs_valloc: dup alloc
cpuid = 0
Uptime: 21s
Automatic reboot in 15 seconds - press a key on the console to abort
--> Press a key on the console to reboot,
--> or switch off the system now.

 

All this allows me to do is reboot the vSRX.

 

This is continuous and I cannot get the vSRX to actually go to the CLI. It just keeps getting to this point and power cycling.

 

I only have access to the qcow2 image and have configured that as per the eve-ng vSRX documentation.

 

Maybe there is a dependency too.... The html portal shows the vSRX as being available though...

 

Any ideas as to why this is happening please?

 

9 REPLIES 9
Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

[ Edited ]
‎12-30-2019 04:06 AM

Add on to the above information:

 

I downloaded the qcow2 image from Juniper and it is the same size as the file I already have.

Again, I followed the procedure shown on the Juniper site:

Copy file to directory created. (Used SCP)

Rename file to "virtioa.qcow2"

Re-apply fixpermissions.

 

I am using eve-ng Community on VMWorkstation 12.

I am still having the same problem where the vSRX is just constantly power cycling. As I have mentioned above, I have no problem at all with the vMX.

 

 

Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

[ Edited ]
‎01-03-2020 01:35 AM

Hi,

 

what vSRX Version are you trying to spin up?

Are you using the default Template from EVE-NG or did you change Settings (especially RAM or CPU)?

Have you tried other vSRX Versions to see if this behavior is also affecting other images?

 

 

--
Best Regards

Christian Scholz
JNCIE-SEC :: Juniper Networks Ambassador :: Telonic (Germany)
https://www.jncie.eu
Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-05-2020 07:55 AM

Hi Christian,

 

I am using the version that is also available on the Juniper vMX and vSRX sebsite.

 

The VM is in VMware Workstation 12 and is being run on a Tower system (plenty of power). I changed the CPU is 8 and the memory is 16gb. I am running the VM in bridged mode as the IP Address will remain the same. This is for external connectivity and that works fine.

 

I had been informed that a "Serial Port" was required for the VM that the vSRX is running on so I have added that too and it has made no difference at all.

 

As i said, the vMX is running perfectly and I have no issues with that. Just the vSRX.

 

I cannot try a different version as I have no other version qcow2 image.

 

Thanks

Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-06-2020 02:33 AM

Have you already tried to "wipe" the vSRX after you changed the CPU and RAM?

Power it off, right-click it and select "wipe" - after that power it up again.

 

Serial is not needed on the Host as far as I know (at least I don't have one and everything works fine).

Are you running the latest EVE-NG?

 

 

--
Best Regards

Christian Scholz
JNCIE-SEC :: Juniper Networks Ambassador :: Telonic (Germany)
https://www.jncie.eu
Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-08-2020 11:26 AM

Hi Christian,

 

So, I have got a little further. Purchased a new machine, re-installed VMware Workstation 12 Pro.... Re-installed the eve-ng.ova and created the VM. Gave the VM 16GB RAM and 8 CPUs. Bridged interface as easier and also statically assigned the MAC on the router to ensure same address always applied.

 

Re-installed vMX and re-installed vSRX

 

Opened the portal and created a new lab. Created vMX-Control-Plane and Forwarding-Plane and they work fine. No issues, as per before.

 

This time when I created the vSRX in the lab, I gave it 4 x CPU and 8192 RAM. So, I got to a logon prompt this time.... But now I get to the following point when I try and enter the CLI:

 

login: root

--- JUNOS 19.2R1.8 Kernel 64-bit XEN JNPR-11.0-20190517.f0321c3_buil
root@:~ # cli
<xnm:error xmlns="http://xml.juniper.net/xnm/1.1/xnm" xmlns:xnm="http://xml.juniper.net/xnm/1.1/xnm">
<message>
could not open render database schema: /var/run/db/render.db.qxiFkKrD
</message>
</xnm:error>
could not initialize the renderer
root@:~ # ~
veriexec: no fingerprint for file='/root' fsid=85 fileid=118272 gen=147665435 uid=0 pid=93961
/root: Authentication error.
root@:~ #
root@:~ # conf
conf: Command not found.
root@:~ # cli
<xnm:error xmlns="http://xml.juniper.net/xnm/1.1/xnm" xmlns:xnm="http://xml.juniper.net/xnm/1.1/xnm">
<message>
could not open render database schema: /var/run/db/render.db.fbDCrLmn
</message>
</xnm:error>
could not initialize the renderer

 

So, a little further but stuck still....

Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-10-2020 02:45 AM

I think there's something wrong with the image itself.

I also had a similar error once and this was due to a bad file.

Let me try to get someone from JNPR to send you a known working file 🙂

--
Best Regards

Christian Scholz
JNCIE-SEC :: Juniper Networks Ambassador :: Telonic (Germany)
https://www.jncie.eu
Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-13-2020 12:40 PM

Hi Christian,

 

Thank you for the help. I have now installed vSRX-NG and it works perfectly so I think you are correct.

 

I do have a quick question for you as an add on please (it is quick)...

 

Does the vSRX require a license to enable PPPoE (MLPPP at the server end)? I have configured correctly but yet only sends out a PADI with no response, but I have noticed the following in the license output:

 

root# run show pppoe version
Point-to-Point Protocol Over Ethernet, Version 1. rfc2516
Maximum sessions = 1024
PADI resend timeout = 2 seconds
PADR resend timeout = 16 seconds
Maximum resend timeout = 64 seconds
Maximum configured AC timeout = 2 seconds

 

I think there should be a line that says "pppoe = enabled" ... but there is not, and also the license information:

root> show system license
License usage:
Licenses Licenses Licenses Expiry
Feature name used installed needed
logical-system 0 3 0 permanent
Virtual Appliance 1 1 0 59 days
remote-access-ipsec-vpn-client 0 2 0 permanent

Licenses installed:
License identifier: E420588955
License version: 4
Software Serial Number: 20150625
Customer ID: vSRX-JuniperEval
Features:
Virtual Appliance - Virtual Appliance
count-down, Original validity: 60 days

 

 

Thanks

 

 

Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-13-2020 12:55 PM

Actually, it appears that it is working but I am getting the following as a response:

 

IO send ... PADI for pp0.0
Jan 13 20:49:46 Discovery Input: PADO packet received on uifl (idx 72)
Jan 13 20:49:46 Malformed packet: no ac name field in incoming PADO packet
Jan 13 20:49:49 IO send ... Packet resend for pp0.0
Jan 13 20:49:49 Discovery Input: PADO packet received on uifl (idx 72)
Jan 13 20:49:49 Malformed packet: no ac name field in incoming PADO packet
Jan 13 20:49:54 IO send ... Packet resend for pp0.0

Highlighted
vSRX

Re: eve-ng vSRX Constantly power cycling

‎01-14-2020 01:04 AM

Hi,

 

usually, you have a 60day License for everything.

So in theory (if you are doing the PPPoE over ge- instead of reth) PPPoE should work.

 

PPPoE over redundant Ethernet interface

Note: Starting in Junos OS Release 15.1X49-D100 and Junos OS Release 17.4R1, vSRX supports Point-to-Point Protocol over a redundant Ethernet interface (PPPoE).

Not supported

 

However I don't know PPPoE very well - so you might start a new Topic for this issue 🙂

Glad, that your vSRX is working now.

--
Best Regards

Christian Scholz
JNCIE-SEC :: Juniper Networks Ambassador :: Telonic (Germany)
https://www.jncie.eu
Feedback