vSRX
vSRX

how to configure vSRX as cluster in eve-ng

‎02-05-2020 01:11 PM

Hello guys,

 

can someone help me to figure out how to configure vSRX as cluster please ? i understood which interfaces to ue for th eFabric link , but my issue is with the control link still struguling to understand how to do it as in documentation is mention em0 , but it seems no physical connection like fabric link no ?

 

can you assist or advise .

 

highly appreciated .

 

Cheers

fad

3 REPLIES 3
Highlighted
vSRX

Re: how to configure vSRX as cluster in eve-ng

‎02-05-2020 04:37 PM

Hi Fadito,

 

I haven't done it my self but as far as I could see/investigate it can be done following the conventional method, just make sure you meet the pre-requisites and be aware of a few caveats using EVE :

 

https://www.juniper.net/documentation/en_US/vsrx/topics/task/multi-task/security-vsrx--kvm-chassis-c...

 

Caveat: Clustering on Juniper SRX with EVE

 
For SRX to support clustering, here are few things to keep in mind 
 
The SRX in Cluster mode runs fairly well on EVE , however the interface mappings on EVE is different than regular. This is due to the SRX getting a new interface (em0) as second interface Card – so if you select ge-0/0/0 in EVE, you really select em0.
 
EVE is platform and is Clustering unaware. So you will have to tweak a few things 
 
From top down the first Interface in EVE is fxp0, the second Interface is em0, the third is ge-0/0/0 or 7/0/0, the fourth is ge-0/0/1 or 7/0/1 and so on (see the Table below from Juniper)
 
 
 
 

Regards,
Lil Dexx JNCIE-ENT#863

 

If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

 
Highlighted
vSRX

Re: how to configure vSRX as cluster in eve-ng

‎02-10-2020 07:13 AM

Thanks LilDexx ! 

 

appreciated ! i will check it again and see how to proceed as it seems a bit copmlex task mainly du eto the fact EVE is platform and is Clustering unaware. 

 

cheers !

 

fadi 

Highlighted
vSRX

Re: how to configure vSRX as cluster in eve-ng

‎05-25-2020 01:01 PM
Thanks Lildexx.

I have been trying to get a basic cluster setup and operational today and for the life of me I couldn't understand why it wouldn't come up. I kept googling around and nothing. I then stumbled upon your reply post - this has fixed it and the cluster is working in eve-n.

Thank you.
Feedback